Pulled hair out on this one... fresh install of OES2/dsfw, namcd wouldn't load. /var/log/mesages looked lke:

Code:
May 27 13:34:00 myserver /usr/sbin/namcd[6371]: Starting namcd..
May 27 13:34:00 myserver /usr/sbin/namcd[6371]: namcd populating the user hash tables
May 27 13:34:00 myserver /usr/sbin/namcd[6371]: User profile file cannot be opened/does not exist
May 27 13:34:00 myserver /usr/sbin/namcd[6371]: Failed to populate user hash tables from file, namcd populating the hash tables from eDir
May 27 13:34:04 myserver /usr/sbin/namcd[6371]: ldap_initconn: LDAP bind failed (error = [49]), trying to connect to alternative LDAP server
May 27 13:34:04 myserver /usr/sbin/namcd[6371]: Unknown error returned reading configuration parameter: alternative-ldap-server-list
May 27 13:34:04 myserver /usr/sbin/namcd[6371]: _nds_nss_struct_init: Error [226] in _nds_ldap_private_struct_init.
May 27 13:34:04 myserver /usr/sbin/namcd[6371]: Problem in namcd initialization, exiting...

May 27 13:34:06 myserver /usr/sbin/namcd[6371]: Deleted hash tables and flushed data into local files
May 27 13:34:06 myserver /usr/sbin/namcd[6371]: Deinitialized threads
Tried alternate ldap servers, various combinations. Verified with other tools that ldap was in fact functioning, ssl certs were all valid and in the right place, etc.

Resolution:

My nam.conf contained the following:
Code:
proxy-user-fdn=cn=LUM-proxy,ou=orgunit,o=org
proxy-user-pwd=password!@#
The problem was either the exclamation point, the at-sign, or the pound sign. Changed the password to "password123" (and also on the eDir user object) and namcd started right up, happy as a (insert your own trite phrase here).