I am aware that this thread is six years old; however, I want to help anyone looking for a quick solution. It took me a while figure this out on my own, and this was the first thread that I came upon while looking for this solution.

It is now possible to disable the Z icon overlays in ZENworks 11. To remove the icon overlays, go to your Novell ZENworks Control Center > Configuration > Expand Device Management > ZENworks Explorer Configuration > Uncheck: Disable Icon Overlays.