I am writing to ask for some assistance with one of our nodes
has problems opening the edirectory database.

I managed to carry out some diagnostics where by I restarted the server
with out startup or autoexec.ncf which then allowed me to load up in
stages and then allow me to carry out a NSS rebuild of the SYS volume.
Majority of the Novell support tids were forwarding me on to NSS
rebuild of the pool to get the volume back - the problem was that SYS
was not even mounting due to corruption.
Once it completed, rebooted the server and boots up with most services
looking ok..until it trying to load the cluster services and Edirectory,
my hunch is that because it cant load the Edirectory properly that might
be having an adverse effect on everything else.
Once the server boots up to its server console, I get the following

could not open local database -610

I've tried numerous dsrepair checks as per a few of the Novell support
tids - relating to the local database, but with the dsrepair screen
states that it cannot find any servers.

I am not sure what else to do - as this is looking like it cant find
any Edirectory at all. Ive tried to unload DS and reload but it says
cannot open local database.
The other servers are prompting cannot communicate with SBNODE2.

Is there anyway we can re-install Edirectory back onto this cluster node, because this is not just a standard NetWare built server..but rather a clustered server I am not sure what effects can happen when doing that type of task as im not 100% knowledgeable in Novell clustering to know what to do.

I am able to load up startx gui and view the volume: SYS and see all the contents in the volume - files & folders.
When i run Dsrepair - I noticed within the dsrepair at the top of the screen normally you see:
tree name:
Serve name:

I am only seeing server name: SBNODE2
The tree name is blank.

When I try run a timesync within dsrepair - it responds back with :
The directory services database is closed
Try running the local database repair

The server console also displays the following:

Directory services: local database has been closed
Directory services: could not open local database, error -610

The server looks like its up, with exception to the navispshere, cluster services loaded as it cant find the network path to the SAN properly probably due to Edirectory not being available.
Im not sure exactly what to do now.
From what I can see - maybe a reinstallation of Edirectory, but how - on a clustered node?

We are running:

Netware 6.5 sp8
Cluster service / sbd - 1.8.5 -501
10 node cluster