Hi,

SYSTEM:
SLES 10.2 (Updated via local SMT Server)
OES2/SP1 (Updated via local SMT Server)
eDirectory 8.8.5

I recently encountered a problem on one of my servers when it get to the point of "Starting DHCP server" during boot it completely hang.

At this moment dhcp is removed during bootup, tried to load it manual but still the same issue where it just hangs, though when I ssh to the box and rcdhcpd status it show "running". The moment I "rcdhcpd stop" status goes to "dead" and not "unused" as previous.

The process still run in the backround so when I start again it obiously state another process running:

root 17977 0.0 0.0 2808 1368 pts/0 T 11:23 0:00 /bin/sh /usr/sbin/rcdhcpd start

dhcpd 17995 0.0 0.0 0 0 pts/0 Z 11:23 0:00 [dhcpd] <defunct>


What was done so far:

I have reconfigured DHCP via OES(Yast) after removing all subnets, dhcp-server objects from edir.

I remove network config re-added it default (device name eth-003-blabla) and made sure in "/etc/sysconfig/dhcpd" corrosponds.

I have changed it to just "eth0" and made sure it reflects in "/etc/sysconfig/dhcpd"

Tested with a single subnet, no luck.

Added lines to /etc/dhcp.conf (below) like other forums suggested with authoritative/ldap-username/ldap-password, no luck:

Here is all my configs

===================================
---------------------------------------------
/etc/sysconfig/dhcpd
---------------------------------------------

#
DHCPD_INTERFACE="eth0"

## Type: yesno
## Default: yes
## ServiceRestart: dhcpd
#
# Shall the DHCP server dhcpd run in a chroot jail (/var/lib/dhcp)?
#
# Each time you start dhcpd with the init script, /etc/dhcpd.conf will
# be copied to /var/lib/dhcp/etc/.
#
# Some files that are important for hostname to IP address resolution
# (/etc/{hosts,host.conf,resolv.conf,localtime}, /lib/libnss_dns.so.2,
# /lib/libresolv.so.2) will also be copied to the chroot jail by the
# init script when you start it (about 100kB altogether).
#
# The pid file will be in /var/lib/dhcp/var/run/dhcpd.pid.
#
DHCPD_RUN_CHROOTED="no"
===================================
---------------------------------------------
/var/log/dhcp-ldap-startup.log
---------------------------------------------
ddns-update-style none;
option nortel-callserver code 128 = string;
subnet 10.2.0.0 netmask 255.255.0.0 {
default-lease-time 259200;
option routers 10.2.1.1;
option domain-name-servers 10.7.200.30,10.6.200.30;
option domain-name "santam.co.za";
option nortel-callserver "VLAN-A:109.";
pool {
range 10.2.1.41 10.2.2.254;
}
}
===================================
---------------------------------------------
/etc/dhcpd.conf
---------------------------------------------
authoritative;
ldap-username "cn=admin,o=santam_za";
ldap-password "************";
ldap-server "10.2.1.9";
ldap-port 636;
ldap-ssl ldaps;
ldap-base-dn "ou=Services,ou=PretoriaCOE,o=SantamZA";
ldap-method static;
ldap-debug-file "/var/log/dhcp-ldap-startup.log";
ldap-dhcp-server-cn "DHCP_s00200109";
ldap-referrals on;
ldap-tls-reqcert never;
===================================
---------------------------------------------
/var/log/messages during start
---------------------------------------------

Jun 24 12:17:04 s00200109 dhcpd: Internet Systems Consortium DHCP Server V3.0.3
Jun 24 12:17:04 s00200109 dhcpd: Copyright 2004-2005 Internet Systems Consortium.
Jun 24 12:17:04 s00200109 dhcpd: All rights reserved.
Jun 24 12:17:04 s00200109 dhcpd: For info, please visit DHCP | Internet Systems Consortium
Jun 24 12:17:04 s00200109 dhcpd: Internet Systems Consortium DHCP Server V3.0.3
Jun 24 12:17:04 s00200109 dhcpd: Copyright 2004-2005 Internet Systems Consortium.
Jun 24 12:17:04 s00200109 dhcpd: All rights reserved.
Jun 24 12:17:04 s00200109 dhcpd: For info, please visit DHCP | Internet Systems Consortium
Jun 24 12:17:05 s00200109 dhcpd: Wrote 0 leases to leases file.
Jun 24 12:17:05 s00200109 dhcpd: Listening on LPF/eth0/00:21:5e:c2:24:a0/10.2/16
Jun 24 12:17:05 s00200109 dhcpd: Sending on LPF/eth0/00:21:5e:c2:24:a0/10.2/16
Jun 24 12:17:05 s00200109 dhcpd: Sending on Socket/fallback/fallback-net
Jun 24 12:17:22 s00200109 ndpapp[10276]: nds_nss_GetFDNfromUID: failed to init socket, status = 0
Jun 24 12:17:22 s00200109 kernel: Couldn't get FDN from LUM for uid=886, rc=2
Jun 24 12:17:22 s00200109 ndpapp[10278]: nds_nss_GetFDNfromUID: failed to init socket, status = 0
Jun 24 12:17:22 s00200109 kernel: Couldn't get FDN from LUM for uid=886, rc=2
Jun 24 12:17:25 s00200109 dhcpd: DHCPINFORM from 10.2.1.155 via eth0
Jun 24 12:17:25 s00200109 dhcpd: DHCPACK to 10.2.1.155
Jun 24 12:17:29 s00200109 dhcpd: DHCPINFORM from 10.2.1.155 via eth0
Jun 24 12:17:29 s00200109 dhcpd: DHCPACK to 10.2.1.155
Jun 24 12:17:48 s00200109 ps: nds_nss_GetPwdbyUid: failed to init socket, status = 0
Jun 24 12:17:48 s00200109 ps: nds_nss_GetPwdbyUid: failed to init socket, status = 0
Jun 24 12:18:22 s00200109 dhcpd: DHCPINFORM from 10.2.1.64 via eth0
Jun 24 12:18:22 s00200109 dhcpd: DHCPACK to 10.2.1.64
Jun 24 12:18:27 s00200109 dhcpd: DHCPINFORM from 10.2.1.64 via eth0
Jun 24 12:18:27 s00200109 dhcpd: DHCPACK to 10.2.1.64
===================================

You will notice I created a option 128 for VIOP and tag a VLAN ID (109) via the date subnet. Trust me, even without this option and tag it will not work.

This issue is ONLY on this server, no other. I know i am missing something stupid, not sure what. Please help!

Jaco