Ok, I've gotten a server that has been updated to OES SP2.
rug pd -i shows
S | Name | Version | Category
--+----------------------------+---------+---------
i | SUSE_SLES_SP3 | 10.3-1 | base
i | OPEN_ENTERPRISE_SERVER_SP2 | 2.0.2-0 | add-on

Which is ok.

rug sl shows
# | Status | Type | Name | URI
--+--------+------+-------------------------------------+-----------------------
1 | Active | NU | https://nu.novell.com | https://nu.novell.com
2 | Active | ZYPP | SUSE Linux Enterprise Server 10 SP3 | ftp://172.16.1.109/...
3 | Active | ZYPP | Novell Open Enterprise Server 2 SP2 | ftp://172.16.1.109/...

Which is ok (our media's are on a local ftp server).

rug ca shows
Sub'd? | Name | Service
-------+-------------------------------------+------------------------------------
Yes | SUSE Linux Enterprise Server 10 SP3 | SUSE Linux Enterprise Server 10 SP3
Yes | Novell Open Enterprise Server 2 SP2 | Novell Open Enterprise Server 2 SP2
| SLES10-SP3-Online | https://nu.novell.com
Yes | OES2-SP2-Pool | https://nu.novell.com
Yes | OES2-SP2-Updates | https://nu.novell.com
Yes | SLES10-SP3-Updates | https://nu.novell.com
Yes | SLES10-SP3-Pool | https://nu.novell.com
| SLE10-SP3-Debuginfo-Updates | https://nu.novell.com
| SLE10-SP3-Debuginfo-Pool | https://nu.novell.com
| SLE10-SP3-Debuginfo-Online | https://nu.novell.com

rug lu shows
S | Catalog | Bundle | Name | Version | Arch
--+-------------------------------------+--------+---------------------------+-------------------+-------
v | SUSE Linux Enterprise Server 10 SP3 | | acl | 2.2.41-0.15 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | apparmor-utils | 2.1.1-0.9 | noarch
v | SUSE Linux Enterprise Server 10 SP3 | | audiofile | 0.2.6-17.6 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | audit | 1.2.9-6.19 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | audit-libs | 1.2.9-6.19 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | bind-libs | 9.3.4-1.29 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | bind-utils | 9.3.4-1.29 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | bzip2 | 1.0.3-17.9 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dbus-1 | 0.60-33.22 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dbus-1-glib | 0.60-33.22 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dbus-1-mono | 0.60-33.25 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dbus-1-python | 0.60-33.25 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dbus-1-x11 | 0.60-33.25 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dhcpcd | 1.3.22pl4-223.13 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | dialog | 0.9b-204.2.2 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | emacs | 21.3-224.17 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | emacs-info | 21.3-224.17 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | emacs-x11 | 21.3-224.17 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | file-roller | 2.12.3-0.23 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | freetype2 | 2.1.10-18.20 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | ghostscript-fonts-other | 8.15.4-16.11 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | ghostscript-fonts-std | 8.15.4-16.11 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | ghostscript-library | 8.15.4-16.11 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | ghostscript-x11 | 8.15.4-16.11 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | gnutls | 1.2.10-13.19 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | gpg2 | 1.9.18-17.19 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | gstreamer010-plugins-good | 0.10.2-16.23 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | hplip-hpijs | 0.9.7-19.9 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | latex2html-pngicons | 2002.2.1-379.5 | noarch
v | SUSE Linux Enterprise Server 10 SP3 | | libacl | 2.2.41-0.15 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libgimpprint | 4.2.7-62.22 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libicu | 3.4-16.10 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libjasper | 1.701.0-16.10 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libsndfile | 1.0.12-13.10 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libsoup | 2.2.90-18.24 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libxml2 | 2.6.23-15.20 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | libxslt | 1.1.15-15.11 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | limal-ca-mgm | 1.1.75-0.3 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | limal-ca-mgm-perl | 1.1.75-0.3 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | logrotate | 3.7.3-13.8 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | mdadm | 2.6-0.18 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | mingetty | 0.9.6s-88.6 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | mono-core | 1.2.2-12.27 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | mono-data | 1.2.2-12.27 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | mono-web | 1.2.2-12.27 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | mono-winforms | 1.2.2-12.27 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | nautilus | 2.12.2-64.55 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | nfsidmap | 0.12-16.20 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | OpenEXR | 1.2.2-16.7 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | openmotif-libs | 2.2.4-21.17 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | opensc | 0.9.6-17.12 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | perl | 5.8.8-14.10 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | portmap | 5beta-749.18 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | qt3 | 3.3.5-58.37 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | resmgr | 0.9.8_SVNr75-18.9 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | vim | 6.4.6-19.15 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | wget | 1.10.2-15.11 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | wireless-tools | 28pre13-22.19 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | xerces-j2 | 2.7.1-16.7 | noarch
v | SUSE Linux Enterprise Server 10 SP3 | | xfsprogs | 2.9.4-3.6 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | xscreensaver | 4.23-20.12 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | xterm | 208-14.6 | i586
v | SUSE Linux Enterprise Server 10 SP3 | | yast2-vm | 2.13.79-0.3 | i586


Which is quite a lot of patches.

But rug up -t patch shows
No updates are available.

It doesn't matter if I do a rug cc or reboot the server.

Now what?