My Satellite Servers have the Authentication Role but it will not authenticate. It seems my servers are missing a file called ZenAuthServer.exe

[DEBUG] [06/25/2010 11:08:28.731] [1056] [ZenworksWindowsService] [14] [] [AuthSatelliteModule] [] [Authentication Server is NOT installed] [] []
[DEBUG] [06/25/2010 11:08:28.731] [1056] [ZenworksWindowsService] [14] [] [AuthSatelliteModule] [] [Authentication Server service is not installed] [] []
[DEBUG] [06/25/2010 11:08:28.762] [1056] [ZenworksWindowsService] [14] [] [AuthSatelliteModule] [] [Unable to create service ZenAuthServer. Service ZenAuthServer was not found on computer '.'.] [] []

[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [AuthSatelliteModule] [] [Registering Auth Satellite prop page with SatelliteServer] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [SatSrvPropPage] [] [Registering SatelliteServer property sub-page: Authentication (ID: AuthSatellitePage)] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [SatSrvPropPage] [] [Adding Satellite Server property page to Z-icon] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [SatSrvPropPage] [] [Satellite Server Page Group. ID: Satellite Server, MergeOrder: 60
Sub-page Authentication (ID: AuthSatellitePage), MergeOrder: 11
Sub-page Imaging (ID: ImagingServerPage), MergeOrder: 11
Sub-page Collection (ID: CollectionPointPage), MergeOrder: 15
Sub-page Content (ID: DistributionPointPage), MergeOrder: 30
] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Initialize() for module com.novell.zenworks.module.AuthSatelliteModule returned successfully] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Start() for module com.novell.zenworks.module.AuthSatelliteModule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\AuthSatellite.dl l] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Start() for module com.novell.zenworks.module.AuthSatelliteModule returned successfully] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Initialize() for module com.novell.zenworks.module.quicktaskmodule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\QuickTaskManager .dll] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Initialize() for module com.novell.zenworks.module.quicktaskmodule returned successfully] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Start() for module com.novell.zenworks.module.quicktaskmodule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\QuickTaskManager .dll] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Start() for module com.novell.zenworks.module.quicktaskmodule returned successfully] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Initialize() for module com.novell.zenworks.module.policymodule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\Novell.Zenworks. PolicyManager.dll] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Initialize() for module com.novell.zenworks.module.policymodule returned successfully] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Start() for module com.novell.zenworks.module.policymodule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\Novell.Zenworks. PolicyManager.dll] [] []
[DEBUG] [06/28/2010 15:35:40.135] [1216] [ZenworksWindowsService] [14] [] [AuthSatelliteModule] [] [Found 0 instances of ZenAuthServer.exe] [] []

[DEBUG] [06/28/2010 15:35:41.119] [1216] [ZenworksWindowsService] [14] [] [AuthSatelliteModule] [] [Attempting to configure service using: C:\Program Files (x86)\Novell\ZENworks\bin\ZenAuthServer.exe //US//ZenAuthServer --Description "The ZENworks satellite server authentication service provides user authentication for ZENworks managed devices" --DisplayName "Novell ZENworks Authentication Server" --JavaHome "C:\Program Files (x86)\Novell\ZENworks\share\java" --Jvm "C:\Program Files (x86)\Novell\ZENworks\share\java\bin\server\jvm.dl l" --JvmOptions "-Djava.security.auth.login.config=C:\Program Files (x86)\Novell\ZENworks\share\ats\etc\svc\casa-jaas.conf;-Dcom.novell.casa.authtoksvc.config=C:\Program Files (x86)\Novell\ZENworks\share\ats\etc\svc;-Djava.security.krb5.conf=C:\Program Files (x86)\Novell\ZENworks\share\ats\etc\svc\krb5.conf;-Dlog4j.configuration=file:C:\Program Files (x86)\Novell\ZENworks\share\ats\etc\svc\log4j.prop erties" --Classpath "C:\Program Files (x86)\Novell\ZENworks\java\lib\jetty-service.jar;C:\Program Files (x86)\Novell\ZENworks\java\lib\core\org.eclipse.os gi_3.4.0.jar" --StartMode jvm --StartClass com.novell.zenworks.agent.jettyservice.JettyServic e --StartMethod serviceStart --StartParams -console;1234] [] []



Am I missing some install insturctions or is something not happening on my server that should be?

I would love to get Satellite Authentication working to take some load off the Primary Servers and to keep the authentication local to the site. Thanks

-Mike