I have just installed a zencm server 10.3, have discovered the pc's on our network, have then deployed the agent on two pc's, let's call them 'A' & 'B', both running W7. Please note that both A & B are freshly installed pc's, NOT reimaged pc's.

'A' shows up under devices
'B' does not show up under devices

it's clear to me that ZEN is handling or interpreting the GUID totally wrong, but where to look?is it the deployment package that does not reset the guid correctly after deployment?
I already tried the zac fsg -d via the command line, but that just makes A & B swap places, i.e. B shows up under devices and A doesn't anymore

as long as this guid issue is not solved, I can not proceed with rolling out the new zen.... seems like such a basic thing

I don't seem to be the only one having this issue, although most threads talk about this issue in relation to (re)imaged pc's - which is not the case here...both pc's have had W7 installed from the install DVD

any help is more than welcome
thanks in advance