We have been able to image E6410s as long as they were connected to 100Mb links rather than 1000Mb but new laptops we are getting from Dell will not image, we even tried an old 10Mb hub. The existing E6410 laptops we have still image just fine.

Early in the boot process after PreWork (Pty) is displayed the blue bar countdown (backoff,timeout,resend) repeatedly tries to download something. Once the countdown finishes the following error is displayed:

ERROR: The server did not respond as requested in time.
ERROR: No Response from port map service.

The laptops have Intel 82577LM Gigabit Ethernet. We have discovered that our working laptops have
PCI\VEN_8086&DEV_10EA&SUBSYS_040A1028&REV_05\3&115 83659&0&C8
and the non-working are
PCI\VEN_8086&DEV_10EA&SUBSYS_040C1028&REV_05\3&115 83659&0&C8
(the SUBSYS has an A in the working laptop and a C in the one that doesn't work)

I monitored the attempted PXE boot with wireshark and I can see the laptop appear to successfully download dinic.sys. After the download is finished the laptop repeatedly sends ARP packets for the subnets gateway.
The laptop shipped with Bios revision A03 patch 2, we tried the A04 update with no changes. We have two Precision M4500 laptops, one that was ordered a few weeks ago imaged fine and was deployed. A more recently ordered M4500 has the same problem as the new E6410 laptops we got.
We tried updating to ZEN7SP1IR4_HP4-June_2010 and the most recent DINIC.SYS without any changes.