I recognize that the preferred way to install updates (i.e. 10.3.0 to 10.3.1) is to deploy the update on the server and let the machine discover the update. What I would like to see,however, is fixing the deployment packages, PreAgentPkg_agent.exe, so that it will install the latest version of the agent regardless of whether a previous agent is installed. I don't want the software to tell me the agent is already installed, unless it's the same version I am installing. If the agent is older, why can't the installer update it and force it to refresh it's connection to the server?