I am currently running a pretty stable environment of 10.2.0. I also didn't apply 10.3 due to recommendations by others. So should I now move to 10.3.1? Is it stable? Also, when with Novell stop supporting 10.2.0?

Thanks in advance,

Eric Bolton