It is strange that I did add a filter in the bundle requirement by
restricting OS version has to be <=5.1 (which is smaller than xp) but
windows 2007 (64-bit) workstation still gets the bundle and then
generates the error because the bundle does not apply to it. By the way,
this is the only filter I put in the bundle. Can someone give advice? Do
I miss anything?

Thank you very much!