So I'm sure most of us know about the latest round of Adobe Flash/Reader vulnerabilities. I've been watching patch management every day to be able to test out the latest 10.1.82.76 upgrade and today I noticed it popped up, but I appear to only have the non-IE browser version.

Has anyone gotten the IE version of 10.1.82.76 yet? All I show today is...

Adobe Flash Player 10.1.82.76 (Other Browsers) for Windows (Full/Upgrade) (All Languages)
Adobe APSB10-16 Flash Player 10.1.82.76 (Other Browsers) for Windows (Update) (All Languages)