We are using a certificate from Network Solutions, rather than a self-signed certificate. I used OpenSSL to create a CSR and a private key. Submitted the CSR to Network Solutions. Got a certificate, combined it with the private key, renamed it mobility.pem and put it in the proper folder, as well as server.pem in its proper folder.

We have used certificates from Network Solutions for all of our other needs with out issue, but this one seems to be causing a problem. If I navigate to the website https:/mydomainname.com:443 I should at least be able to verify the certificate, even though it will show a blank page. I can and there are no problems.

Yet, when I try to configure a Droid, I get a cannot connect to the server, or a security issue. I checked the logs and the mobility log does show my incoming connection. I open the web browser on the Droid and go to the https://mydomainname.com:8120, I get a certificate error as well.

I have tried copying the certificate to the sdcard on the Droid and importing it. Still the same problem.

So I am back to the certificate that I requested from Network Solutions. Do I not have correct private key? I put the private key before the certificate when creating the mobility.pem. Am I supposed to be chaining the other certificates that Network Solutions included together in a single file (haven't needed to do the before). If so, does the private key precede all of the certificates?

Any help would be great.