Greetings, running SLES10SP3/OES2SP2, on this server I've noticed when I
login through the GUI, that the icon on the bottom right that will show an
exclamation mark if there's updates pending, has not been doing so for some
time (just showing the globe). If however I go into the YAST - ONLINE
UPDATE, there's some available (a lot the first time I ran it). I've seen
this before where I have to run this manually to update some installation
source and then after the icon in the bottom right will start alerting me to
updates, but this is several times now and it isn't (for instance there's an
eDir update that it's not telling me about).

However on another SLES10SP3/OES2SP2 test box that I hadn't turned on in a
while, if I fire that up, the orange exclamation mark appears.

If I right click the updater icon on both systems and choose CONFIGURE, I
notice differences. The non-functional system shows 1 entry pointing to the
installation source for SLES10SP3, the functioning system shows this
(actually to SLES10SP2) as well as Also if I go to
the CATALOGS tab on both, the non-functioning system only shows "SUSE Linux
Enterprise Server 10 SP3-20100219-191656", whereas the working system shows
this and a bunch of other items which mirrors what I find in the YAST -
on the non-functioning system also shows all the entries that it should.

The only difference between these 2 systems is the functioning one was
originally a SLES10SP2/OES2SP1 install which I ran the upgrader on, whereas
the non-functioning one was installed from SLES10SP3/OES2SP2 media directly.
The non-functioning one was working fine (including the updater icon) for
quite a while. As mentioned above I have not been running or updating the
functioning one for a while now, so it's possible that there was some update
that affected the non-functioning server.

Any ideas? I think I can simply add in the missing SERVICES tab entry, will
this add the CATALOG ones too? Why would they have disappeared?