I am currently running BM 3.8 sp2 on NW6.5 sp2.

Is NW6.5sp5 good to go yet, or should I just patch to sp4?