Hello, I have been trying to get the gwha to restart the mta without success. Here is my setup: SLES 10sp3(with OES2) Groupwise 801. This is a secondary domain for now, I planning on moving the gwia and webacc once I figure out the problem with gwha and gw monitor. Another issue is that gw monitor has to be started manually?? Here are some config files:
/etc/xinet.d/gwha
service gwha
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /opt/novell/groupwise/agents/bin/gwha
instances = 1
type = UNLISTED
port = 8400
disabled = yes
}
/etc/init.d/grpwise-ma
#! /bin/sh
#
# /etc/init.d/grpwise-ma
#
### BEGIN INIT INFO
# Provides: grpwise-ma
# Required-Start: $local_fs $network
# Should-Start: ndsd namcd novell-nss
# Required-Stop: $local_fs $network
# Should-Stop: ndsd namcd novell-nss
# Default-Start: 3 5
# Default-Stop: 0 1 2 6
# Short-Description: Novell GroupWise Monitor Agent
### END INIT INFO
#

#Monitor Agent Config data

MA_CONFIG=/opt/novell/groupwise/agents/share/monitor.xml
MA_BIN=/opt/novell/groupwise/agents/bin/gwmon

# To enable the GroupWise High Availablilty service to allow the Monitor
# Agent to restart other GroupWise agents, uncomment the following line
# and provide a valid Linux user and password. The Linux user does not
# need any specific permissions. The --hapoll option controls how often,
# in seconds, that the Monitor Agent polls to determine if an agent is running.
# You may also add other Monitor Agent startup options to this variable.

MA_OPTIONS="--hauser gwha --hapassword Secret --hapoll 90"
MA_OPTIONS="--httpmonuser webagent --httpmonpassword password"
/opt/novell/groupwise/gwha.conf
[gwha]
ssl = no
key =
cert =
password =

[ssmddom]
server = /opt/novell/groupwise/agents/bin/gwmta
command = /etc/init.d/grpwise
startup = ssmddom.mta
delay = 2
wait = 10

Any help will be greatly appreciated,