I have been living with a problem for a while, but now I have duplicated
the problem against 10.3.1, I've decided to ask for help.

We mostly assign bundles to groups from an AD data source. I have also
imported admin users from the same AD data source for our (small:)
Zenworks team.

All of us admins have experienced losing all our icons in the Novell
Application Window. Workarounds that have worked on some PCs include
logging in and out from the zenworks notify icon, zac cc, deleting the
Windows user profile, reinstalling the Adaptive agent. In several cases
we have reinstalled operating systems to get our icons back.

Over time its gotten worse. My user account and one of my colleagues
has no user-assigned icons at all, not on any Windows XP, Windows 7 or
Windows 2003 Terminal Server (Citrix Xenapp), and none of the
workarounds work anymore.

I have tried removing my user as a Zenworks administrator with no luck.
Adding it back as admin also didn't change anything.

Haven't found any similar problems on google, novell forums or KB.

Production environment is still sitting at 10.2.2, but my test
environment (which runs against the same AD data source) is fully
patched, and exhibits the same problem with the same users.

Any ideas?