i've been trying this past week to create a reference image for our hypervisors platform. Since we have access to zen it seemed like a nice way to ensure that all my hypervisors are alike.

But for some reason zenwork imaging cannot seem to restore correcly a sles in a bootable state.

I'm running on HP bl460c g6

disk part are
/dev/cciss/c0d0p1 *Linux reiserfs 40960
/dev/cciss/c0d0p2 Linux swap 8195
/dev/cciss/c0d0p3 Linux reiserfs 90819
/dev/cciss/c0d0p3 empty 0

I tried first using zcm 10.3 and i got a server that would not boot. However the partition was readable using a live cd.
I tried copying the mbr from my source using dd but it went no where.
I then tried zcm 11 rc3 with the same result.
Then i realised that i might have partition table problem and rebuilt my image by first creating partition using zcm instead of yast partitionner.

I now have a server that present me menu.lst in black and white and return an error 17

So either grub does not read my file system or he cannot see my partition.
I checked the filesystem and it's clean
fdisk confirm that the partition table is valid.

using Sles 11 recovery mode i can make this server bootable but the automated tool reinstall grub

i can only conclude that zcm break the mbr

i did mbr copy on target and source and used file to confirm that all was well. Both copies and valid mbr with good partition table. But using hexdump on both files return vastly different results.

hum... help i'm running out of hair?

Joke aside this should be fixed.