Hi.

I have to config a cluster that was installed by someone else 1/2 year ago, and I'm
not very familiar to OES-LX and NCS... :-(

I *DID* readup all the "file_cifs_lx.pdf", everything looks OK, so pls let me ask:

0.) where to get more detailed documantation and examples covering CIFS on OES-LX
and NCS, especially trouble shooting?


Both OES nodes' versions are:

Novell Open Enterprise Server 2.0.2 (x86_64)
VERSION = 2.0.2
PATCHLEVEL = 2
BUILD = FCS

SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
PATCHLEVEL = 3



1.) failing to connect "\\server-W" using CIFS:

UID and universal password are defined/set, at least for the users I personally and
explicitely tried to login.

CIFS is installed already on both nodes, and rcnovell-cifs is running (both).

I cannot connect using the node's cifs server name as shown in iManager -CIFS Admin:

start, run, \\oesnode02-W

will bring up a login box, but I fail to login. the context of all users is added
for the nodes, I tried just the username ("user"), also the full DN
(cn=user,o=context and .cn=user.o=context).

Error messages in the cifs.log posted below.

Propably this will have to be solved first....


2.) Cluster load / unload lines.

I found this one http://tinyurl.com/depoycifs (typo is correct ;->> )

It shows for the cluster configuration lines that match the lines I see for the NSS
volume cluster resource, that shall be accessed using CIFS.

And a line like this extra. When I putty submit this line on the node that currently
has mounted the NSS volume, I get the following error.

OESNode02:~ # novcifs --add --vserver=.cn=nw06goe.o=edv.t=ggtree --ip-addr=10.27.1.51
Adding a Virtual Server is failed
Error : Unknown , Error Number: -626

when I first stop rcnovell-cifs, the error is this one:
Connecting to the CIFS server failed, so I assume, that rcnovell-cifs has to run
before submitting that like commands?



Two things I cannot quite place:

1.) every user that logs in to eDir seems to generate one CIFS login error: The CIFS
server name is different from the virtual server name everybody is mapping a drive
letter to at login time. (OESNODE02-W <-> NW06GOE)
--------------------------------------------------------------------------
Nov 24 05:50:14 OESNode02 CIFS[8614]: WARNING: CODIR: Failed to authenticate User :
tr
Nov 24 05:50:14 OESNode02 CIFS[8614]: WARNING: CODIR: Failed to authenticate User :
tr
Nov 24 05:50:14 OESNode02 CIFS[8614]: CRITICAL: AUTH: Login
Failed.tempSES->nwLoginError is -601
Nov 24 05:50:14 OESNode02 CIFS[8614]: CRITICAL: AUTH: Login
Failed.tempSES->nwLoginError is -601
--------------------------------------------------------------------------


2.) When I try to login using the full LDAP user I get lines like this:
--------------------------------------------------------------------------
Nov 24 14:58:38 OESNode02 CIFS[8614]: CRITICAL: AUTH: Failed to fetch credentials of
User : cn=admin,O=main Nmasldap-error : -1659 , ProxyUser-
cn=cifsProxyUser-OESNode02,o=main . Check Configuration
--------------------------------------------------------------------------


The ProxyUsers for both nodes exist, and I found TIDs stating that CIFS wouldn't
even load if the proxyuser is broken / missing?



Any suggestions appreciated,


Regards, Rudi.