I've been trying to get the managed device to recognize the configured location, but I can't achieve it.

I have a Windows 2008 R2 x64 server. It is the only PS in the zone (RC3). It's IP Address is and the gateway is

I configured a "Network Environment" (ZCC > Configuration > Locations):
- Minimum Match: 2
- Adapter type: All
- Gateway: (match required)
- Client IP Address: (Static or DHCP) (match required)
- other tabs are blank

I want all the IPs in the range "10.1.1.xxx". This is required to distinguish between ".21" and ".210", ".211", ".212", etc.
We also have some switches that share a range, so one network could be, and the other Between the IP address and the gateway, we can distinguish them.

I also configured a location with an "Assigned Network Environment" point to the entry above.

On ZCC, the "Reference Count" for the Network Environment and Location is "0".
On the adaptive agent (same server) the "configuration location" is: "~unknown~". I even tried modifying the "Client IP Address" to It is still unknown. Tried rebooting too.

Please help!