My problem is trying to update from ZCM 10.3.0 to 10.3.1 on a W2k3 server, initial deployment "completed with error", but in trying to redeployment, it stuck with "rebuilding deployment packages", the condition pressist no matter what I try. Our enironment are mixture of w2k3 and w2k8, 3 VM zen server of wk3 and a w2k8 sql server. It's only the first primary server that I try installing 10.3.1 on with 10.3.0 as the baseline. I ran zdc using zcm_10.3.1.zdc, it yield some interesting results. Lots of missing files:
The one that interest me are under Zenworks file verifier:

C:\Program Files\Novell\CASA\ad_ff.dll
C:\Program Files\Novell\ZENworks\bin\preboot\mfc80.dll.... mostly mfcxxxx.dll
C:\Program Files\Novell\ZENworks\bin\preboot\ZISWIN.EXE
C:\Program Files\Novell\ZENworks\bin\XmlSerializers\PatchModu le.XmlSerializers.dll
C:\Program Files\Novell\ZENworks\bin\modules\PatchModule.dll
C:\Program Files\Novell\ZENworks\bin\preboot\Microsoft.VC80.C RT.manifest
C:\Program Files\Novell\ZENworks\bin\preboot\Microsoft.VC80.M FC.manifest
C:\Program Files\Novell\ZENworks\bin\preboot\Microsoft.VC80.M FCLOC.manifest
C:\Program Files\Novell\ZENworks\conf\resources\PatchModule.c onf
Lots of msi was missing
C:\Program Files\Novell\ZENworks\install\downloads\msi\novell-xxxxx.msi
C:\Program Files\Novell\ZENworks\install\downloads\msi\novell-tftp-

C:\Program Files\Novell\ZENworks\install\downloads\msi\novell-zenworksxxxxxxxxxxxx.msi

C:\Program Files\Novell\ZENworks\install\downloads\rpm\CASA_a uth_token_jaas_support-1.7.1627-0.noarch.rpm
C:\Program Files\Novell\ZENworks\install\downloads\rpm\CASA_a uth_token_svc-1.7.1631-0.noarch.rpm
C:\Program Files\Novell\ZENworks\install\downloads\rpm\novell-proxydhcp-10.3.1-60738.i586.rpm
C:\Program Files\Novell\ZENworks\install\downloads\rpm\novell-tftp-10.3.1-60738.i586.rpm
lots of rmp was missing
C:\Program Files\Novell\ZENworks\install\downloads\rpm\novell-zenworks-xxxxxxxxxxxxxxxxxx.rpm
C:\Program Files\Novell\ZENworks\lang\PatchModule_de.dll
C:\Program Files\Novell\ZENworks\lang\PatchModule_es.dll
Lots of Jar files was missing
C:\Program Files\Novell\ZENworks\lib\java\xxxxxxxxxx.jar

There are also warning about extra files such as the following:
C:\Program Files\Novell\ZENworks\lib\ImageDataBridge.dll
C:\Program Files\Novell\ZENworks\share\tomcat\webapps\busines sobjects\enterprise115\desktoplaunch\help\de\webin telligence\accessible\webhelp.jar
C:\Program Files\Novell\ZENworks\share\tomcat\webapps\busines sobjects\enterprise115\desktoplaunch\help\de\webin telligence\html_query\webhelp.jar
C:\Program Files\Novell\ZENworks\share\tomcat\webapps\busines sobjects\enterprise115\desktoplaunch\help\de\webin telligence\html_report\webhelp.jar
C:\Program Files\Novell\ZENworks\share\tomcat\webapps\busines sobjects\enterprise115\desktoplaunch\help\de\webin telligence\java\webhelp.jar

There are also some inconsistency files such as the following
ERROR File 'C:\Program Files\Novell\ZENworks\bin\ColW32.exe' is inconsistent!!!
Size: expected = 2818320, actual = 2826512
Checksum: expected = dcf39fd6, actual = a48542fb

ERROR File 'C:\Program Files\Novell\ZENworks\bin\LzmaLib.dll' is inconsistent!!!
Size: expected = 53248, actual = 53248
Checksum: expected = d04684a3, actual = 4a8aa79b

ERROR File 'C:\Program Files\Novell\ZENworks\bin\Novell.Zenworks.MDStatus .dll' is inconsistent!!!
Size: expected = 36864, actual = 36864
Checksum: expected = f18d7959, actual = 37f27e53

ERROR File 'C:\Program Files\Novell\ZENworks\bin\XmlSerializers\Novell.Ze nworks.MDStatus.XmlSerializers.dll' is inconsistent!!!
Size: expected = 32768, actual = 32768
Checksum: expected = 74fa3ff1, actual = e81e3f8d

ERROR File 'C:\Program Files\Novell\ZENworks\conf\loader\serverstats.xml' is inconsistent!!!
Size: expected = 1078, actual = 187
Checksum: expected = 5f083b81, actual = a02b3dee

ERROR File 'C:\Program Files\Novell\ZENworks\install\downloads\msi\CasaAu thTokenServer.msi' is inconsistent!!!
Size: expected = 10959872, actual = 10966016
Checksum: expected = e1091c42, actual = d3da5e24

ERROR File 'C:\Program Files\Novell\ZENworks\install\downloads\msi\authto kenclient.msi' is inconsistent!!!
Size: expected = 960512, actual = 652800
Checksum: expected = 1b5d704d, actual = b33460d4

Also missing objects in the database table
Missing object in table 'NC_NetworkPrinter_Consumable'
Object type: [Index] , Object name: [idx_NDConsumable_OID]
Detail: [Name: idx_NDConsumable_OID, Table: NC_NetworkPrinter_Consumable]

ERROR Missing object in table 'zActionSetActionTie'
Object type: [Index] , Object name: [idx_ActionSetActionTie_AS]
Detail: [Name: idx_ActionSetActionTie_AS, Table: zActionSetActionTie]

ERROR Missing object in table 'NC_NetworkPrinter_Alert'
Object type: [Index] , Object name: [idx_NDAlert_OID]
Detail: [Name: idx_NDAlert_OID, Table: NC_NetworkPrinter_Alert]

ERROR Missing object in table 'zSystemUpdateRequires'
Object type: [Index] , Object name: [idx_zSUReq_SystemUpdateEx]
Detail: [Name: idx_zSUReq_SystemUpdateEx, Table: zSystemUpdateRequires]

Key points are :-

[LIST][*]What i was wondering is whether I can just copy the missing files from my dev zen server that had 10.3.1 upgraded without any issue and whether it will fix the problem I had, so I can redeploy 10.3.1?
[*]What causes ZCC to be Blank?
[*]Does this problem causes us the problem of unable to register devices to this server?

Can this also causes a slow logon?
Thanks in advance if anyone out there able to look at this and provide a solution for us. By the way , a SR was already logged with Novell, except that my manager really need this resolved asap, like now.