I am in the middle of a phased upgrade from 10.2.0 to 10.3.1. I got back from lunch and noticed that my 10.3.1 update says 'superceded'. When I cleared out the updates and rechecked, 10.3.1 doesn't even show up as an option! This is a problem because I spent a lot of time testing 10.3.1 making sure it wouldn't mess up our environment. Does this now mean I need to stop and go back to testing, upgrading the servers, etc?????