Login Script mappings are taking more than a minute per map to happen

I've tried all three (that I know of) ways of mapping
MAP ROOT INS S1:=.TEMPO_SYS.Petroff:\Public
Map Root P:=\\fs2\SHARED\users\%LOGIN_NAME
Map Root P:=\\\SHARED\users\%LOGIN_NAME
Map Root P:=.fs2_SHARED.Mar.Petroff:\users\%LOGIN_NAME

initial authentication happens fast, I see the login script come down
to the workstation and it runs fast until a mapping, and then it just
sits there. At a packet level I don't see the workstation doing much
between mappings, its like it is just waiting for about a minute before
it starts actually running through the mapping process which it does in
under a second once it starts.

Have seen this on all 3 Windows 7 boxes in this environment, All Ultra,
2 are 64-bit, one is 32-bit. It doesn't make a difference between the
pair of old NetWare 6.5.8 boxes or the new virtualized OES2/SLES
systems. Have tried pointing to the old SLP on NetWare and the new
OpenSLP on the SLES boxes with no difference. We've seen this problem
from the beginning with the original Novell Client 2, and on through up
to the most current (2,sp1,IR5). None of the servers have CIFS
running, and the state (on, Off, removed) of the CIFS client doesn't
make a difference. Less than half of the mappings are root.

Have certainly found and fixed a few other problems seen in those
packet captures, but not this most key problem that means logins can
easily take over a half hour. We are at crunch time as we now up to the
point where we need to deploy some Windows7 system, and the users will
certainly not tolerate that long a login.

Andy Konecny
KonecnyConsulting.ca in Toronto
Andy's Profile: http://forums.novell.com/member.php?userid=75037