We've got a problem with the failback of paths to our SAN components.

We are having a NetWarecluster connected to a SAN.
It consists of two NetWare 6.5sp8 servers ( for iPrint) with NCS installed, 2 HBAs connected with 2 paths to two brocade switches which are again with two paths connected to two Falcon IPStor servers doing storage virtualization.

With "list failover devices" 4 paths are listed and everything works fine.
Now when a failover occurs (switch or serverside => 2 paths are disconnected) the paths are disconnected alright but after a failback the paths are not reconnected properly.
When a second failover happens the server abends (SBD partition is not reachable) with a "fatal SAN error".

Now we do not have any ideas, why the reconnected paths are not recognized properly by the server. We varied the parameters of the driver as you can see in the startup.ncf I paste here:
(drivers are QLE2462, ql2x00.ham version 6.90.02, we tried a newer one but with no success)

The startup.ncf of the iPrint servers:
set multi-path support=on
LOAD ACPIDRV.PSM
######## End PSM Drivers ########
LOAD IDECD.CDM
LOAD SCSIHD.CDM
######## End CDM Drivers ########
LOAD IDEATA.HAM SLOT=10023
LOAD MEGA_SAS.HAM SLOT=10024
#LOAD QL2X00.HAM SLOT=301 /LUNS /allpaths /portnames /qualified
#LOAD QL2X00.HAM SLOT=302 /LUNS /allpaths /portnames /qualified
#LOAD QL2X00.HAM SLOT=301 /LUNS /portdown=150 /xretry=60 /xtimeout=120
#LOAD QL2X00.HAM SLOT=302 /LUNS /portdown=150 /xretry=60 /xtimeout=120
#LOAD QL2X00.HAM SLOT=301 /LUNS /xportdown=120 /xretry=60 /xtimeout=120 /lunzero /allpaths
#LOAD QL2X00.HAM SLOT=302 /LUNS /xportdown=120 /xretry=60 /xtimeout=120 /lunzero /allpaths
LOAD QL2X00.HAM SLOT=301 /LUNS /ALLPATHS /XRETRY=120 /XTIMEOUT=240 /PortDown=240 /LUNZERO
LOAD QL2X00.HAM SLOT=302 /LUNS /ALLPATHS /XRETRY=120 /XTIMEOUT=240 /PortDown=240 /LUNZERO
######## End HAM Drivers ########
LOAD KEYB.NLM Germany
LOAD CHARSET.NLM CP850
env NDSD_TRY_NMASLOGIN_FIRST=true

We also do have a file services cluster (4node NetWare6.5 SP8, NCS) which works well and failover, failback is no problem with this cluster:
startup.ncf:
#LOAD POWPATH.CDM
set multi-path support=on
LOAD ACPIDRV.PSM
######## End PSM Drivers ########
LOAD IDECD.CDM
LOAD SCSIHD.CDM
LOAD BAKPLANE.CDM
######## End CDM Drivers ########
LOAD IDEATA.HAM SLOT=10006
LOAD LSIMPTNW.HAM SLOT=10015
LOAD LSIMPTNW.HAM SLOT=10016
#LOAD QL2X00.HAM SLOT=3 /LUNS /allpaths /portnames /qualified
#LOAD QL2X00.HAM SLOT=4 /LUNS /allpaths /portnames /qualified
########am 18.05.10, wegen Falconstor, KS #################
LOAD QL2300.HAM SLOT=3 /LUNS /allpaths /xportdown=120 /xretry=60 /xtimeout=120 /lunzero
LOAD QL2300.HAM SLOT=4 /LUNS /allpaths /xportdown=120 /xretry=60 /xtimeout=120 /lunzero
#LOAD QL2X00.HAM SLOT=3 /LUNS /ALLPATHS /XRETRY=60 /XTIMEOUT=120 /LUNZERO
#LOAD QL2X00.HAM SLOT=4 /LUNS /ALLPATHS /XRETRY=60 /XTIMEOUT=120 /LUNZERO
######## End HAM Drivers ########
Load Keyb Germany
Load Charset CP850
env NDSD_TRY_NMASLOGIN_FIRST=true


Bettina
University of Hamburg,
Germany