OK, so I'm using "Novel iFolder 3.8 Administration Guide" to enable (or force) SSL connection on Ubuntu 10.10.

Section 7.10.2 (and 8.5.2.) states to modify file /etc/apache2/vhosts.d/vhost-ssl.conf. However, I don't have a file vhost-ssl.conf anywhere, so I omit this section. The only files ending with *ssl.conf are:


However, there's nothing about SSLCipherSuite directive.

Section 7.10.3 states to enable SSL in the admin panel on "System" tab. The "SSL option" isn't available for me. The drop-down list isn't enabled, and it states "NONSSL". Is it because of the previous vhost-ssl.conf file?

However, when I go to "Servers" tab, and then open "Host 1", it states "LDAP SSL: Yes".

Section 8.5.3 states to modify file /usr/lib/simias/webAdmin/Web.config. I don't have this file, so I modify the following two files:


and change "http" to "https":

<add key="SimiasUrl" value="https://localhost:80/" />
<add key="SimiasCert" value="" />
However, when I then go to https://domain.com/admin or http://domain.com/admin, I can't log in, en error says that the connection with the server failed. Is it because I leave value of SimiasCert empty?

Section 8.5.4 states to modify file /etc/apache2/conf.d/ifolder_web.conf. Again, I don't have this file, so I modify the following files:


and remove comments as follows:

#Remove comments below this line to enable SSL
LoadModule rewrite_module /usr/lib/apache2/mod_rewrite.so
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/ifolder/(.*) https://%{SERVER_NAME}/ifolder/$1 [R,L]
There's no error when I go to http://domain.com/admin or http://domain.com/ifolder, but they don't redirect me to either https://domain.com/admin or https://domain.com/ifolder, respectively. Why? When I go directly to https address it works fine, but I want to force https when somebody opens http address.

Bottom line. I'm quite confused with the guidelines, as both sections 7.10 and 8.5 deal with SSL, and they are overlapping. I'm not sure about the actual steps involved to enable and force SSL connection.

Many thanks for your help.