Hi! I'm in the process of testing all my bundles that I use on Windows XP Pro x86 in Windows 7 Pro x64. Usually the bundles works right away. But I'm having problems with the bundle requirements part. For example, I just created a bundle for "Adobe Acrobat Pro 10.0.1" which verify this:

Registry Keys exists - NO
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{AC76BA86-1033-F400-7760-000000000005}
AND
Achitecture = 32

This works great on 32 bits. But when I install this bundle on a 64 bits system, it install correctly but my bundle requirements then fail. Because now it should be something like:

Registry Keys exists - NO
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows\CurrentVersion\Uninstall\{AC76BA86-1033-F400-7760-000000000005}
AND
Achitecture = 64

So my question now his how can I set up my bundle requirements so that it can detect if I'm on a x86 or a x64 system and verify the proper registry branch? Is it even possible on 10.3.1? Right now I create 2 bundles for the same application. One for the x86 and the other for the x64!

Thanks in advance for the help!