Compared to the old GMS this is a fantastic product.
Unfortunately it will not run very well, or it might be that it does not scale when we add more users to the system.

Datasync engine stops working and we can not see any errors.

If we use web interface to stop the Mobility engine in web interface it hangs.
GroupWise engine stops without any errors.
We can restart from a console with command: rcdatasync restart

After a restart the systems works immediately but stops working after some time.
To make it work we have setup a CRON job every fourth hour to restart datasync.
After adding some more users we can not guarantee that the system runs for more than 2 hours

Earlier we had problems with SOAP and the old Intellisync (GMS) but with datasync we have free SOAP threads on the POA

I have looked at all the log files under /var/logs/datasync but I can only find any obvious error. The only error I can find is described later in this text.

At the moment we have connected our system to 11 subdomains.
Some of the links are slow, slowest is a 2 mbps to Malaysia 240 ms.
We have around 150 users/devices in the system.

Datasync is running as a virtual machine with 6 GB RAM and 2 CPU. Utilization is not near maximum.

What makes me frustrated is that I can not see what is causing the system to stop and that I do not get any warnings. Users are starting to get frustrated and we need to find a solution.

We run:
SLES 11 sp1
Update 3 of datasync (v1.1.0.2159)
GroupWise 8.02 hp2 on Netware

In default.pipeline1.mobility-AppInterface.log I can see an error message about the same time as sync stops working.

2011-03-02 09:36:53.740 INFO [Thread-4] [syncEngineEventMonitor:119] [userID:cn=SEUAM0,ou=USERS,ou=SE2,ou=Euro_North,o=F LS] [eventID:default.pipeline1.groupwise-source-soapbridge.380fb02b44a811e0aa72005056b04043] [objectID:3859be0f44a811e0aa72005056b04043] [CheckPoint] Processed Event

2011-03-02 09:36:57.871 ERROR [Thread-7] [GenericApplicationInterface:491] [userID:] [eventID:] [objectID:] [] Error attempting connection to Sync Engine: [Errno 24] Too many open files

2011-03-02 09:36:57.874 INFO [Thread-7] [attachmentMonitor:124] [userID:] [eventID:] [objectID:] [AttachmentMonitor] Problem getting attachment 124595:2354954.pdf from Sync Engine.

2011-03-02 09:36:57.875 ERROR [Thread-7] [attachmentMonitor:142] [userID:] [eventID:] [objectID:] [AttachmentMonitor] Unable to download attachment 124595:2354954.pdf from Sync Engine.

2011-03-02 09:36:57.876 ERROR [Thread-7] [attachmentMonitor:147] [userID:] [eventID:] [objectID:] [AttachmentMonitor] Failed Downloading Attachment 124595.

Any ideas how to find out if this is causing our problem and how to solve it?
Can I change the number of allowed open files?