Can VPN be established between BorderManager2.1 and 3.7? Will there be

any problem?

Can VPN be established between BorderManager3.7 and checkpoint NG FP3?

Will there be any problem?