This is a followup to a question I posted August 2010. When upgrading 10.2.2 to 10.3.0a, the primary crashed badly and had to be reinstalled. I restored mismatched database and server info backups (yeah, I know, really dumb), but was able to work around the resultant issues and have a system that works great.

Except - ZCC still shows the primary server with ZCM version and Agent version 10.1.2. The installed packages are all 10.3.0.xxxx, and under assigned system updates for the server, 10.3.0a shows update completed. Curiously, patch management (which I do not use) shows the correct version.

The problem now is I can't get any further updates to run on the primary. 10.3.1 is assigned, but will not install, and I can only assume it's because of the wrong version number. Does anyone know of a way to force (or at least encourage) the server to update its version information in ZCC?