I'm having two issues when disconneting iSCSI services on my NetWare 6.5 SP6 server. ISCSINIT.NLM is 1.06.05.

(1) From the NetWare console prompt using the 'iscsinit disconnect' command.

From the NetWare console prompt, 'iscsinit info' reports an active iSCSI sessions, as expected. However, if I run the 'iscsinit disconnet' command (iscsinit disconnet 10.111.11.1, for example), the console prompt returns but the session remains; there is no output to either the console or the logger screen. (I also tried dismounting the associated NSS volume prior to running the 'iscsinit disconnect' command with the same result.) I'm just wondering, how can I disconnect my iSCSI sessions using the console prompt?

(2) When using Novell Remote Manager.

The disconnect works, but the following messages appear on the console:

Deactivating pool "ISCSI"...
Dismounting Volume IVOL1

Mar 31, 2011 10:41:57 am NSS<COMN>-3.25-xxxx: comnPool.c[2672]
Pool ISCSI: System data I/O error 20204(zio.c[2260]).
Block 1640197(file block 6424)(ZID 3)


Mar 31, 2011 10:41:57 am NSS<ZLSS>-3.25-1449: zfsVolumeData.c[212]
Error reading VolumeData Block 6554504, status=20206.


Mar 31, 2011 10:41:57 am NSS<ZLSS>-3.25-1449: zlssLogicalVolume.c[4948]
Error reading PoolData Block 6554502, status=20206.


Mar 31, 2011 10:41:57 am NSS<ZLSS>-3.25-1449: zfsVolumeData.c[212]
Error reading VolumeData Block 6554499, status=20206.


Mar 31, 2011 10:41:57 am NSS<ZLSS>-3.25-1449: zlssLogicalVolume.c[4948]
Error reading PoolData Block 6554502, status=20206.