All of our workstations are members of our domain, as are faculty/staff users, but our students are not. This has always worked fine, with faculty/staff users authenticating to the domain and students authenticating locally via DLU (controlled by ZCM).

After we updated to ZCM 10.3.3 earlier this week, students (ie non-domain users) can no longer login to any workstations. They authenticate via the Novell client just fine, but are quickly prompted that "The local computer username or password is not valid" and they can't get anywhere.

What we've tried thusfar:
Clearing ZCM cache on workstation and server.
Refreshing ZCM agent on devices (while logged in as a dlu user - see below).
Editing DLU policy and incrementing.
Associating DLU to workstations in addition to user.
Removing Random Time to Wait under the Device Refresh Schedule within ZCC.

We can see within the ZCM agent properties that the DLU policy is applying, but it's simply not allowing local logins. Domain users have no problems logging in.

We can manually remove the domain\username to be workstation\username at the second prompt which allows users to login, but there's absolutely no way that will work long-term. Tweaking the Default Login Profile under the Novell Client configuration to reflect the above change does not work either, as workstations still want to authenticate against the domain first, workstation second.

As an aside: We found the update to 10.3.3 to be quite perilous, having to go around to over half of our workstations and manually uninstall ZCM and CASA, only to re-install it. We actually canceled the deployment of 10.3.3 once it had gotten to half of our workstations because it was so problematic. Workstations that didn't get the 10.3.3 update and are still on 10.3.2 work just fine with DLU. This includes Win7 non-SP1, Win7 SP1, and WinXP SP3 workstations.

Any information that you can offer would be greatly appreciated, as this is starting to become a major problem for us and we have no budget to open a ticket with Novell.