Hi! I'm trying to figure out why I get on many computers, but not on all, warning and error messages about my "Package redistribuable Microsoft Visual C++ 2005 SP1". The requirements are this:

Registry key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{7299052b-02a4-4627-81f2-1818da5d550d}
Not Exist
AND
x86

OR

Registry key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DevDiv\VC\Se rvicing\8.0
Not Exist
AND
x64

But when some computers check if it can apply this bundle some pop up the error "BUNDLE.SysReqFailed" saying that the registry key for the x64 version doesn't exist! So I open regedit and check and YES it does exist! So what am I missing here?!?! I also get a lot of this in the logs.

Code:
 [DEBUG] [04/13/2011 15:05:30.242] [1396] [ZenworksWindowsService] [23] [] [ContentManager] [] [metadataUpdatedNeeded = False] [] [] 
 [ERROR] [04/13/2011 15:13:57.944] [1396] [ZenworksWindowsService] [64] [] [launcher configuration policy] [POLICYHANDLERS.CommonClasses.HandlerTimedOut] [CommonClasses.HandlerTimedOut (launcher configuration policy)] [] [de116f306d8ae61951bfb31e6d063bbc] 
 [ERROR] [04/13/2011 15:15:33.900] [1396] [ZenworksWindowsService] [54] [] [BundleManager] [BUNDLE.SysReqFailed] [Impossible de lancer l''ensemble Package redistribuable Microsoft Visual C++ 2005 SP1. Les prérequis système de l''ensemble ne sont pas atteints.] [] [af4b16f7359b9551d7a4b0161ced0e00] 
 [ERROR] [04/13/2011 15:15:40.171] [1396] [ZenworksWindowsService] [46] [] [BundleManager] [BUNDLE.SysReqFailed] [Impossible de lancer l''ensemble Package redistribuable Microsoft Visual C++ 2005 SP1. Les prérequis système de l''ensemble ne sont pas atteints.] [] [af4b16f7359b9551d7a4b0161ced0e00] 
 [ERROR] [04/13/2011 15:16:41.526] [1396] [ZenworksWindowsService] [8] [] [BundleManager] [BUNDLE.SysReqFailed] [Impossible de lancer l''ensemble Package redistribuable Microsoft Visual C++ 2005 SP1. Les prérequis système de l''ensemble ne sont pas atteints.] [] [af4b16f7359b9551d7a4b0161ced0e00] 
 [ERROR] [04/13/2011 15:17:45.112] [1396] [ZenworksWindowsService] [55] [] [BundleManager] [BUNDLE.SysReqFailed] [Impossible de lancer l''ensemble Package redistribuable Microsoft Visual C++ 2005 SP1. Les prérequis système de l''ensemble ne sont pas atteints.] [] [af4b16f7359b9551d7a4b0161ced0e00] 
 [ERROR] [04/13/2011 15:18:47.341] [1396] [ZenworksWindowsService] [55] [] [BundleManager] [BUNDLE.SysReqFailed] [Impossible de lancer l''ensemble Package redistribuable Microsoft Visual C++ 2005 SP1. Les prérequis système de l''ensemble ne sont pas atteints.] [] [af4b16f7359b9551d7a4b0161ced0e00] 
 [ERROR] [04/13/2011 15:18:56.201] [1396] [ZenworksWindowsService] [55] [] [BundleManager] [BUNDLE.SysReqFailed] [Impossible de lancer l''ensemble Package redistribuable Microsoft Visual C++ 2005 SP1. Les prérequis système de l''ensemble ne sont pas atteints.] [] [af4b16f7359b9551d7a4b0161ced0e00]
Thanks in advance for the help!