Playing around with setting up some satellite devices in the network. Currently using a local machine in the same subnet as the server to test. When I configure the device as a satellite, the client picks it up, and shows in the properties on the client as having satellie roles. However, if I click on the content link, I get the following error:

"Object reference not set to an instance of an object"

Also, the Satellite->General link on the properties screen just has the scrolling bar at the very bottom of the properties box and never comes back.

I have also tried setting the box up as a collection only satellite server. When I click on the collection link on the client properties box, I also get the moving progress bar at the bottom of the properties screen and never get the screen updated (though if not a collection role it displays a screen). THe content tab is still broken as detailed above.

I have tried rebooting the workstation but that was no good.

Is another "feature" of 10.3.3 that I have found, or is it something else?