I've got on OES2 SP2 linux server running AFP. When the macs on my network attempt to connect I get an error:

"You entered an invalid username or password. Please try again."

Here is my log after the latest reset:

Apr 14 11:19:44 server afptcpd[6710]: Configuration file has clear text login method set as UAM.
Apr 14 11:19:44 server afptcpd[6710]: Configuration File: Number of minimum of threads set to 3
Apr 14 11:19:44 server afptcpd[6710]: Configuration file: Maximum number of threads set to 32
Apr 14 11:19:44 server afptcpd[6710]: Configuration file has max reconnect period set to 1440 minutes
Apr 14 11:19:44 server afptcpd[6710]: Configuration has ALL AFP versions support (2.2, 3.0, 3.1) set.
Apr 14 11:19:44 server afptcpd[6710]: Configuration file has sharing-from-mac set to 'all'.
Apr 14 11:19:44 server afptcpd[6710]: Configuration file has - writing status log - set.
Apr 14 11:19:44 server afptcpd[6710]: Configuration file has - writing error log - set.
Apr 14 11:19:44 server afptcpd[6710]: set Guest user name guest
Apr 14 11:19:44 server afptcpd[6710]: Configuration file has AUDIT disabled.
Apr 14 11:19:44 server afptcpd[6710]: Configuration file has export all volumes disabled.
Apr 14 11:19:44 server afptcpd[6710]: [status] During reload : Number of volumes mounted - 4
Apr 14 11:19:44 server afptcpd[6710]: [error] Directory Caching failed for Volume - VOL1
Apr 14 11:19:44 server afptcpd[6710]: [status] DESKTOP.AFP was created OK (or already exists.)
Apr 14 11:19:44 server afptcpd[6710]: [status] DESKTOP.AFP/APPL was created OK (or already exists.)
Apr 14 11:19:44 server afptcpd[6710]: [status] DESKTOP.AFP/ICON was created OK (or already exists.)

Any ideas?