Hello,

I have a problem with answering a Mail within GroupWise:

Short description:
A customer sends us an eMail and if we answer this Mail we get back an INVALID HEADER - Information

Long description:
Customer sends us an eMail - header below:
Code:
Return-path: <max.weiss@foreigndomain.com>
Received: from gateway.foreigncompany.com (myserver.mycompany.com [x.x.x.x])
	by mail.mycompany.com with ESMTP; Tue, 19 Apr 2011 11:32:26 +0200
Received: from localhost (localhost.localdomain [127.0.0.1])
	by gateway.foreigncompany.com (Postfix) with ESMTP id 4A96014E9A74
	for <klaus.mueller@mycompany.com>; Tue, 19 Apr 2011 11:33:42 +0200 (CEST)
X-Virus-Scanned: amavisd-new at clearos.lan
Received: from gateway.foreigncompany.com ([127.0.0.1])
	by localhost (gateway.foreigncompany.com [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id 4H+-4slp2oss for <klaus.mueller@mycompany.com>;
	Tue, 19 Apr 2011 11:33:35 +0200 (CEST)
Received: from localhost (localhost.localdomain [127.0.0.1])
	by gateway.foreigncompany.com (Postfix) with ESMTP id B721E14E9CBB
	for <klaus.mueller@mycompany.com>; Tue, 19 Apr 2011 11:33:35 +0200 (CEST)
Received: from EXCHANGE.foreigncompany.com (unknown [10.0.0.4])
	by gateway.foreigncompany.com (Postfix) with ESMTPS id 9FE3C14E9A74
	for <Klaus.Mueller@mycompany.com>; Tue, 19 Apr 2011 11:33:35 +0200 (CEST)
Received: from EXCHANGE.foreigncompany.com ([10.0.0.4]) by EXCHANGE.foreigncompany.com
 ([10.0.0.4]) with mapi id 14.01.0270.001; Tue, 19 Apr 2011 11:32:25 +0200
From:
	=?iso-8859-1?Q?Max_Weiss_=28Wei=DF_Company?=
 =?iso-8859-1?Q?en=29?= <Max.Weiss@foreigndomain.com>
To: Klaus Mueller <Klaus.Mueller@mycompany.com>
Subject: WG: Wtrlt: Undeliverable mail, invalid header section CRM:0004171
Thread-Topic: Wtrlt: Undeliverable mail, invalid header section CRM:0004171
Thread-Index: AQHL/muSVMDW0NwLeUaVjzyS/1PGZJRk3fPAgAABzPCAAAyx8A==
Date: Tue, 19 Apr 2011 09:32:25 +0000
Message-ID: <22A612EB-676A-E011-BFF2-A4BADBAC0D02>
Accept-Language: de-DE, en-US
Content-Language: de-DE
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [ip-adress]
Content-Type: multipart/alternative;
	boundary="_000_22A612EB676AE011BFF2A4BADBAC0D02_"
MIME-Version: 1.0

--_000_22A612EB676AE011BFF2A4BADBAC0D02_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

If I want to answer in GroupWise (8.02) there I got back INVALID-HEADER-Message:

Code:
INVALID HEADER

  Improper folded header field made up entirely of whitespace (char 20 hex):
    To: ...F=20Compa?=\n \n =?UTF-8?Q?ny[...]
Our header from sending Mail contains the following:
Code:
To: "=?UTF-8?Q?Max=20Clinton=20(Wei=C3=9F=20compa?=
 
 =?UTF-8?Q?ny)?=" <max.weiss@foreigncompany.com>
Therefore I think the problem are this line breaks here.
But where is the problem and how to resolve it?


Could this be a GroupWise bug or problem?
Could the link break after "From:" in original-header be the problem so already in customer-mail-header is something wrong?
Could the brackets in sendername be the problem?


Also I noticed something "unnormal":
All other mails with brackets in sendername in GroupWise have " before and after sendername in MIME.
I also tried to recreate the problem from several mail services - but I can't recreate it.

Is there any policy about the " in "From:" of the mail header?
I searched different RFCs but nowhere is anything about " in header.