Hi,

I'm trying to update my OES2SP2 server to sp3. After applying the
latest OES2 and SLES10SP3 patches I instealled the move-to-sp3 patch.

# rug pd -i

S | Name | Version | Category
--+---------------------------------------------+---------+---------
i | Novell-Open-Enterprise-Server-SP3-migration | 2-0 | add-on
i | OPEN_ENTERPRISE_SERVER_SP2 | 2.0.2-0 | add-on
i | SUSE_SLES_SP3 | 10.3-0 | base


But if I try to install the recommended patches from the channels, I'll
get a dependency error:

# rug up -t patch -g recommended && rug ping -a
Resolving Dependencies...

ERROR: Dependency resolution failed:
Unresolved dependencies:
nss-kmp-xen-4.12.2835_2.6.16.60_0.54.5-0.5.x86_64[Novell Open
Enterprise Server 2 SP2 2.0.2-0] needed by
novell-zapi-kmp-default-1.2.3256_2.6.16.60_0.54.5-0.6.1.x86_64[System
packages]
Installing nss-kmp-xen-4.12.2835_2.6.16.60_0.54.5-0.5.x86_64[Novell
Open Enterprise Server 2 SP2 2.0.2-0]
Establishing nss-kmp-xen-4.13.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Pool]
kernel-xen-2.6.16.60-0.77.1.x86_64[SLES10-SP3-Updates] needed by
nss-kmp-xen-4.12.2835_2.6.16.60_0.54.5-0.5.x86_64[Novell Open
Enterprise Server 2 SP2 2.0.2-0]
Can't install
nss-kmp-xen-4.13.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Pool], since
nss-kmp-xen-4.12.2835_2.6.16.60_0.54.5-0.5.x86_64[Novell Open
Enterprise Server 2 SP2 2.0.2-0] is already marked as needing to be
installed
Marking this resolution attempt as invalid.
Installing patch:oes2sp3o-sp3_online-7078-GMC8.noarch[OES2-SP3-Online]
Installing patch:product-oes2-sp3-0-3.noarch[OES2-SP3-Online]
atom:novell-zapi-kmp-default-1.3.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Online]
needed by patch:oes2sp3o-sp3_online-7078-GMC8.noarch[OES2-SP3-Online]
Installing
atom:novell-zapi-kmp-default-1.3.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Online]
message:product-oes2-sp3-message-0-3.noarch[OES2-SP3-Online]

needed by patch:product-oes2-sp3-0-3.noarch[OES2-SP3-Online]
Installing message:product-oes2-sp3-message-0-3.noarch[OES2-SP3-Online]
novell-zapi-kmp-default-1.3.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Pool]
needed by
atom:novell-zapi-kmp-default-1.3.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Online]
Updating

novell-zapi-kmp-default-1.2.3256_2.6.16.60_0.54.5-0.6.1.x86_64[System
packages] to
novell-zapi-kmp-default-1.3.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Pool]
patch:oes2sp3o-sp3_online-7078-GMC8.noarch[OES2-SP3-Online]

needed by message:product-oes2-sp3-message-0-3.noarch[OES2-SP3-Online]
Establishing
novell-zapi-kmp-default-1.3.3223_2.6.16.60_0.54.5-0.7.x86_64[OES2-SP3-Pool]
Establishing

atom:novell-zapi-kmp-default-1.2.3202_2.6.16.60_0.54.5-0.6.1.x86_64[System
packages]
Establishing
atom:novell-zapi-kmp-default-1.2.3256_2.6.16.60_0.54.5-0.6.1.x86_64[System
packages]


I don't understand why the novell-zapi-kmp-default should depend on
nss-kmp-xen. Im using the default kernel and the
novell-zapi-kmp-default package (exalty this version) is allready
installed.

Thank you,

Quirin Pasquay