I've been messing around with this New NBM 3.8. I configured as C2S
using the new iManger method. Everything was working Great. NMAS and
Certificates. However It did not work in the way i had hoped So i
decided to just stay with the Legacy vpn to avoid having to update vpn
clients on 130 PCs in 20 cities..

I attempted to delete the VPN server and C2S configuration in
iManager. But it would not delete. I was patient for about 2 hours
then decided to remove it manually. I deleted many entries under the
"Other Tab" in console one. All the ones starting with vpn. This
successfully deleted the configuration in iManager. I Then uninstalled
Border manager from the server. Reinstalled it, Reapplied NW65SP1A and
reapplied the NBM38SP1 patch. I reinstalled it just in case i removed
critical entires on the server object.

I then tried to configure C2S using legacy method and this is the
error is get whenever AUTHGW trys to load
AUTH: NWPKIGetWrappedServerKey returned error code FFFFFB3DAUTHGW:
Failed to acquire the VPN security keys.
I have done PKIdiag on this server and everything is fine. Recreated
VPN keys several times. Even tried the Schema removal tool and Xtnded
it again.

Im tempted to backup server references and blow this puppy away and
reinstall. Any ideas ?