Being a Novell partner, we have received (and applied) our NFR licenses. Since we haven't got an activation code, we have to manually update and apply the PRUs. Unfortunately, on my ZCM11 appliance I have been unable to do this.

In /etc/opt/novell/zenworks/zman/properties/zman-config.properties, I increase DEBUG_LEVEL to 4 (then restart the appliance).

I download the May PRU and copy it to /q/.

I issue these commands:
cd /etc/opt/novell/zenworks/
zman sui /q/11.0.may11pru.zip -U=Administrator -P=password --debug

On the console, these messages appear:
Debug:attempting to determine if a file has correct privileges
Debug:testing a zip file
Debug:results:Archive: /q/11.0.may11pru.zip
caution: filename not matched: -z
Debug:Unable to find updates for product core and base version 10.1
The update(s) contained in /q/11.0.may11pru.zip will begin importing shortly. You may use ZCC to track the status of your import

In /var/opt/novell/log/zenworks/zman.log, these messages appear:
[DEBUG] [5/3/11 11:17:59 AM] [] [ZMan] [] [Time taken for logger initialisation:641 ms] [] []
[DEBUG] [5/3/11 11:17:59 AM] [] [ZMan] [] [Command: sui /q/11.0.may11pru.zip -U=Administrator --debug --TerminalDevice=/dev/pts/2 --ScreenDimension=6 99 ] [] []
[DEBUG] [5/3/11 11:17:59 AM] [] [ZMan] [] [] [] []
[DEBUG] [5/3/11 11:18:00 AM] [] [ZMan] [] [JSAP File is system-update-import.jsap] [] []
[DEBUG] [5/3/11 11:18:00 AM] [] [ZMan] [] [Time taken for Parsing:537 ms] [] []
[DEBUG] [5/3/11 11:18:00 AM] [] [ZMan] [] [JSAP File is system-update-import.jsap] [] []
[DEBUG] [5/3/11 11:18:00 AM] [] [ZMan] [] [Class:com.novell.zenworks.zman.commands.SystemUpda teHandler, Method:systemUpdateImport] [] []
[DEBUG] [5/3/11 11:18:00 AM] [] [ZMan] [] [Command is run by the administrator: Administrator] [] []
[DEBUG] [5/3/11 11:18:03 AM] [] [ZMan] [] [The update(s) contained in /q/11.0.may11pru.zip will begin importing shortly. You may use ZCC to track the status of your import] [] []
[DEBUG] [5/3/11 11:18:03 AM] [] [ZMan] [] [] [] []
[DEBUG] [5/3/11 11:18:03 AM] [] [ZMan] [] [Command completed in 3769 ms] [] []

In /var/opt/novell/log/zenworks/loader-messages.log, no messages appear at all.

So far everything seems to have gone good (apart from some messages above like 'Unable to find updates for product core and base version 10.1') ...

... but in ZCC > Configuration > System Updates
- no updates appear at all
- I (correctly) get the warning 'You cannot receive new updates because System Update entitlement has not been configured.'

I even tried to edit the content of 11.0.may11pru.zip according to http://forums.novell.com/novell-prod...st2095343.html