I'm a little confused by the following problem.

I've got a filter on a cursor that selects all messages that have not got a custom field set, like so:
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
    <ns3:createCursorRequest xmlns="http://schemas.novell.com/2005/01/GroupWise/types" xmlns:ns2="http://schemas.novell.com/2005/01/GroupWise/events" xmlns:ns3="http://schemas.novell.com/2005/01/GroupWise/methods">
      <ns3:view>peek message/RTF delivered subject priority hasAttachments priority size attachments custom email from default recipients sendoptions</ns3:view>
        <element xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="FilterEntry">
          <custom type="String">
On my test server, this filter works beautifully. The cursor produces all messages without this field, and when I run my application that sets the custom field to 1 for all message, it no longer finds anything.

However, when I deploy this exact same filter to my production server, it no longer works. On my production server, where none of the message have this custom field, the filter yields 0 messages (if I run the filter with "exists" instead of "notExist" I also get 0 results).

I'm at a loss to explain why this is. Both servers run Groupwise 8.0.2, my test server on Suse, the production server on Netware.

Anyone have any ideas?