I was going to upgrade Firefox to v4 and received a notice that the
ZCM upload extension was not compatible. The extension was from
10.3.1 and I am now on 10.3.3. Does 10.3.3 have a compatible
extension? Or do I need to hold off on upgrading?

Ken