We have VPN setup and running on a fully-patched BM 3.7 server, and using
the VPN 3.7 client can connect without a problem.

Now we are trying, for no particular reason, to use the 3.8.3 client, and
it's not working.

Error is "Failed to connect to the authentication gateway. Either
[ipaddress] is an invalid VPN server address or the authentication gateway
is not loaded on the VPN server."

But we get this message at the same time that a VPN 3.7 client machine can
successfully connect.

The test machine does not have the Netware client installed on it, but I
don't think that should matter.

The only configuration option that is enabled is "Backwards compatibility."
(All clients are W2K.)

Any thoughts on what might be going wrong?