server is sles 10sp3 oes 2sp.latest.
nic 1 = 192.168.0.16 255.255.255.0 default gateway 192.168.0.2
nic 2 = 10.100.0.16 255.255.0.0

load balancer - virtual ip = 10.100.0.166 points to 192.168.0.16
ip on 192 network is 192.168.0.2 (thus, the default gateway)

I am trying to setup this machine as a GroupWise WebAccess server, whereas it is responding to requests on nic1 via traffic from the load balancer. All other functions of the server are via the 10.x network on nic2.

Working:
1) Accessing the web server from the 192.x network via another machine when both nics are populated.
2) Accessing the web server from the 10.x network (not the load balancer ip) via another machine when both nics are populated.
3) Accessing the web server via the load balancer ip via another machine when only nic1 (192.x) is populated.

Not Working:
1) Accessing the web server via the load balancer ip via another machine when both nics are populated.


ip route:
192.168.0.0/24 dev eth1 proto kernel scope link src 192.168.0.16
10.100.0.0/16 dev eth0 proto kernel scope link src 10.100.0.66
169.254.0.0/16 dev eth0 scope link
192.168.0.0/16 via 192.168.0.2 dev eth1
10.0.0.0/8 via 10.100.0.1 dev eth0
127.0.0.0/8 dev lo scope link
default via 192.168.0.2 dev eth1


netstat -rn:
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
10.100.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
192.168.0.0 192.168.0.2 255.255.0.0 UG 0 0 0 eth1
10.0.0.0 10.100.0.1 255.0.0.0 UG 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.2 0.0.0.0 UG 0 0 0 eth1



Thoughts on what I need to adjust?
Give up and just use round robin dns (on the 10.x network) instead of load balancing two servers?

Thanks for any assistance.