I am experiencing some issues with ZCM 11 imaging a Windows 7sp1 workstation.
Currently we are running Windows XP, 2 partitions. 50GB C:\ and 200GB D:\
I am trying to upgrade the workstations but without recreating D:\

This seems impossible because of these issues:
1. Windows 7 always creates a 100MB "System Reserved" partition /dev/sda1.
If I create a script to delete partition /dev/sda1 (c:\) from the Windows XP Workstation I am of course unable to create /dev/sda1 and /dev/sda2 because /dev/sda2 already exists (D:\) and cannot be "renamed" to /dev/sdb3 (or can it?)

2. If I choose to loose the D:\ and recreate it for Windows 7sp1 and copy the files manually I run into the issue if I want to reimage the new Windows 7sp1 machine.
The Windows 7sp1 workstation now has three partitions /dev/sda1 (100MB) "System reserved" /dev/sba2 (49.9GB) (C:\) and finally /dev/sda3 (200GB) (D:\
If I try to restore partition one and two from my image I seem to run into a bug in the imaging process. If I do a "img restore proxy blah blah -ap:a11" (doing this from memory) it should only restore the 100MB partition. It does not! It restores the first partition, but then happily continue with partition2... After it's done /dev/sbd2 is an unknown file system.

3. If I create a separate image for partition 1 and a separate partition for partition 2 I am unable to restore partition 2. Partition one is fine then "img restore proxy blah blah -ap:a11". But if I restore the second image "img restore proxy blah blah -ap:a12" It always fails half way through the restore with the error that the disk is faulty and I should run a diskcheck. I tried several workstations, all have same issue. I found the issue, but that was a very old one and was fixed in a ZfD 4 fix...