Started a top/down rebuild last weekend ... didn't go well.

- Have a 5-node OES2 Linux Cluster.
- GW 8.0.2 on the back-end.
- Using ConsoleOne on a Windows XP w/s.

- Rebuilt the Primary Domain OK
- Rebuilt 2 Secondary Domains OK (funny thing though, they just showed copying from Primary ?????????).

Started rebuild on first Post Office ... this is where it got bad !
- Via File Explorer, made backup of wphost.db
- Rebuilt to temp location, c:\rebuild\ directory (Copied *.dc file there).
- Downed POA Daemon.
- Replaced wphost.db file with rebuilt one.
- Renamed the wpcsin / wpcsout directories.
- Started POA Daemon ... would not start.
- Had to offline/online the resource to get it to start.

- Couldn't client into any mailboxes.

- POA log showed errors;
- "The database function 29 reported error [C022] on wphost.db", and
- "The database function 29 reported error [C057] on wphost.db"and
- "Error: Data in the database is invalid [C022] User: ... ", and
- "ADM: Completed recovery of the admin database for Post Office ... ".

The Post Office seemed to be continually recovering !

I had to back-out by 1) Downing the daemon and replacing the wphost.db with the backup, and 2) replacing the backed up wpcsin / wpcsout directories.

Not sure what happened ! I even tried an in-place rebuild while the POA daemon was down ... still no go.

Anyone have any ideas ?