A couple of weeks ago I replaced my physical ZCM server with the Virtual Appliance. Aside from some minor issues everything seems to have gone fine with the migration except for now that we are trying to replace systems. On our brand new systems we can register with our Zone and get the initial download of Zen provided services, but after a restart we are not able to sign in and keep getting the "Unable to log into the network because the login credentials or server certificate is incorrect" message.

This is only happening with new or reimaged systems, so am experiencing the same issue with Windows XP and 7 Pro. Here is a the log file from between two login attempts...

[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENResetConnections entered] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ResetConnections()] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ clearing host table] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ clearing IP address table] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ clearing IP URI table] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENResetConnections returning SUCCESS] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENGetAuthoritativeSources entered] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Found Authoritative sources] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ MyZone] [] []
[DEBUG] [06/27/2011 08:39:29.234] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENGetAuthoritativeSources returning SUCCESS] [] []
[DEBUG] [06/27/2011 08:39:31.843] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENIsServerAvailable entered] [] []
[DEBUG] [06/27/2011 08:39:31.843] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Unfiltered zone config list is:] [] []
[DEBUG] [06/27/2011 08:39:31.843] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ https://zenworks.mydomain.com:443/] [] []
[DEBUG] [06/27/2011 08:39:31.843] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ https://x.x.x.214:443/] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject(L4MAP, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [CertManager] [] [x.x.x.214 does not seem to be a certificate subject.] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject(L4MAP, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Filtered zone config list is:] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ https://zenworks.mydomain.com:443/] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [FindFirstContent()] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ ] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [https://zenworks.mydomain.com:443/ ] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ ] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Could not find host: zenworks.mydomain.com] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [Trying to locate source location: https://zenworks.mydomain.com/] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Host name to resolve: zenworks.mydomain.com] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Adding host: zenworks.mydomain.com, status: Unknown] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Host: zenworks.mydomain.com, IP address: x.x.x.214] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Adding IP address: x.x.x.214] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Adding IP Uri https://x.x.x.214/ status: Unknown] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Pinging location: https://x.x.x.214/] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject(PROXY_OVERRIDE, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject(PROXY_DEFAULT, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ZMD] [] [KeepAlive is read from registry. KeepAlive = True] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [CertManager] [] [Checking if host address x.x.x.214 maps to cert subject zenworks.mydomain.com] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [CertManager] [] [Checking if host address x.x.x.214 maps to cert subject zenworks.mydomain.com, alt host names are (zenworks.mydomain.com,x.x.x.214)] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan-ping] [] [ Using uri: https://x.x.x.214/] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [Marking location zenworks.mydomain.com Good at the request of module RemotingService] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Setting location name zenworks.mydomain.com to status Good] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [Marking location x.x.x.214 Good at the request of module RemotingService] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Setting location name x.x.x.214 to status Good] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [Marking location https://x.x.x.214/ Good at the request of module RemotingService] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Setting location name https://x.x.x.214/ to status Good] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Setting location https://x.x.x.214/, IP address x.x.x.214, and host zenworks.mydomain.com to status: Good] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Using location: https://x.x.x.214/, status: Good] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [FindFirstContent() returning https://x.x.x.214/] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENIsServerAvailable returning SUCCESS] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENLogin entered] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Calling SetMiCasaCredential] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Setting credentials with:MyZone] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Setting credentials with:USER] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [SetMiCasaCredential entered] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Calling MiCasa.SetCredential] [] []
[DEBUG] [06/27/2011 08:39:31.859] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [MiCasa.SetCredential using Luid value: 0:686924] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [MiCasa.SetCredential returned] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [SetMiCasaCredential returning] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENGetHostNames entered] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject(L4MAP, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CertManager] [] [x.x.x.214 does not seem to be a certificate subject.] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject(L4MAP, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ZenCache] [] [(Thread 9) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENGetHostNames returning SUCCESS] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Retrieved host names are: ] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ https://zenworks.mydomain.com:443/] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [FindFirstContent()] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ ] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [https://zenworks.mydomain.com:443/ ] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ ] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Found host zenworks.mydomain.com status: Good] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Found location https://x.x.x.214/ status: Good] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [ Using location https://x.x.x.214/ status: Good] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [ConnectMan] [] [FindFirstContent() returning https://x.x.x.214/] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Found zone server https://zenworks.mydomain.com:443/ to be good, continuing] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [About to call ObtainAuthToken] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken entered] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Calling AuthToken.ObtainAuthToken] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [AuthToken.ObtainAuthToken using Luid value: 0:686924] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [AuthToken.ObtainAuthToken will be called with:] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ Host: zenworks.mydomain.com:443] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ ServiceName: com.novell.zenworks.MyZone] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken took exception: -939589628 System.Exception: -939589628
at Novell.Casa.Client.Auth.Authtoken.ObtainAuthToken( String sService, String sHost, WinLuid luid)
at Novell.Zenworks.Zmd.Common.CasaHelper.ObtainAuthTo ken(String SessionID, String RealmName, String Host, String& AuthToken)] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Stack Trace: at Novell.Casa.Client.Auth.Authtoken.ObtainAuthToken( String sService, String sHost, WinLuid luid)
at Novell.Zenworks.Zmd.Common.CasaHelper.ObtainAuthTo ken(String SessionID, String RealmName, String Host, String& AuthToken)] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken returning] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken entered] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Calling AuthToken.ObtainAuthToken] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [AuthToken.ObtainAuthToken using Luid value: 0:686924] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [AuthToken.ObtainAuthToken will be called with:] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ Host: zenworks.mydomain.com:2645] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ ServiceName: com.novell.zenworks.MyZone] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken took exception: -939589628 System.Exception: -939589628
at Novell.Casa.Client.Auth.Authtoken.ObtainAuthToken( String sService, String sHost, WinLuid luid)
at Novell.Zenworks.Zmd.Common.CasaHelper.ObtainAuthTo ken(String SessionID, String RealmName, String Host, String& AuthToken)] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Stack Trace: at Novell.Casa.Client.Auth.Authtoken.ObtainAuthToken( String sService, String sHost, WinLuid luid)
at Novell.Zenworks.Zmd.Common.CasaHelper.ObtainAuthTo ken(String SessionID, String RealmName, String Host, String& AuthToken)] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken returning] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Calling DeleteMiCasaCredential realm: MyZone] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [DeleteMiCasaCredential entered] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Calling MiCasa.DeleteCredential] [] []
[DEBUG] [06/27/2011 08:39:31.875] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [MiCasa.DeleteCredential using Luid value: 0:686924] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [MiCasa.DeleteCredential returned] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [DeleteMiCasaCredential returning] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Calling DeleteMiCasaCredential realm: MyZone.zcmSharedSecret] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [DeleteMiCasaCredential entered] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Calling MiCasa.DeleteCredential] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [MiCasa.DeleteCredential using Luid value: 0:686924] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [MiCasa.DeleteCredential took exception. The error code is: -802] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [DeleteMiCasaCredential returning] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Calling ClearAuthTokenCache] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ClearAuthTokenCache entered] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [Calling AuthToken.CleanUpAuthTokenCache] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [AuthToken.CleanUpAuthTokenCache using Luid value: 0:686924] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [AuthToken.CleanUpAuthTokenCache returned] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ClearAuthTokenCache returning] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [Calling ZENSetSessionAuthenticationState] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENSetSessionAuthenticationState entered] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENSetSessionAuthenticationState returning SUCCESS] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENSetSessionAuthenticationState returned] [] []
[DEBUG] [06/27/2011 08:39:31.890] [1344] [ZenworksWindowsService] [9] [] [RemotingService] [] [ZENLogin returning FAILURE] [] []

Is there anything in the log that helps figure out why I can't log in? I am getting the login and message at both login time and if I try to manually sign in after getting my desktop. Thank you for any assistance!