VPN client connects just fine, I can ping and login to my internal
servers both by address and by name etc. - all is great, but I can't
ping and can't login/map drives to the BM server itself. Ping to (private interface of the BM VPN server) fails. If I try to map
to\sys: I get the error code 8884...

BM 3.8 SP2a Server with 2 interfaces:
Public: 81.x.x.242 with dynamic NAT and no secondary IP addresses.
(NCP Include IP Addresses = set on the server)
The rest of the private network is using different subnets of
C2S service configured and running on the BM server:
Server address: 81.x.x.242/
VPN Server tunnel address:
C2S Service Address Pool: Network
Traffic Rules
1 Encrypt-test - Any User Any Host Any Protocol Encrypt
2. Default_Traffic_Rule - Any User Any Host Any Protocol Deny
Authentication Rules:
Rule User(s) Authentication Action
Admins Specified List NMAS Allow
VPN client connected to the same LAN segment as public interface of the
BM server. Client IP is x.x.x.244.

Tried unloading ipflt to rule out filtering but its still the same
without filters.

Whats more: I can ping (VPN Server tunnel address) from
the VPN client (but I can't map/login using this address - that seems to
be understandable though).

Pawel Mazurkiewicz