When I try to add a user from a secondary PO, this is the response in GW connector log:

2011-07-28 16:58:22.002 DEBUG [CP WSGIServer Thread-3] [gwuser:419] [userID:test] [eventID:] [objectID:] [configureUser] Configuring User "test"
2011-07-28 16:58:22.003 DEBUG [CP WSGIServer Thread-3] [gwsoap:397] [userID:test] [eventID:] [objectID:] [] About to use soap client 27749264 for method loginRequest
2011-07-28 16:58:22.018 DEBUG [CP WSGIServer Thread-3] [gwsoap:462] [userID:test] [eventID:] [objectID:] [] SOAP method loginRequest returned 59923
2011-07-28 16:58:22.018 DEBUG [CP WSGIServer Thread-3] [gwsoap:526] [userID:] [eventID:] [objectID:] [] Done with soap client 27749264 for method loginRequest
2011-07-28 16:58:22.019 DEBUG [CP WSGIServer Thread-3] [gwsoap:587] [userID:test] [eventID:] [objectID:] [] loginRequest: Redirecting this user to POA at address: "http://192.168.2.6:7191/soap"
2011-07-28 16:58:22.669 DEBUG [CP WSGIServer Thread-3] [gwsoap:397] [userID:test] [eventID:] [objectID:] [] About to use soap client 140438720167504 for method loginRequest
2011-07-28 16:58:22.680 DEBUG [CP WSGIServer Thread-3] [gwsoap:600] [userID:test] [eventID:] [objectID:] [] loginRequest: Redirecting this user to POA at address: "https://192.168.2.6:7191/soap"
2011-07-28 16:58:24.053 DEBUG [CP WSGIServer Thread-3] [gwsoap:397] [userID:test] [eventID:] [objectID:] [] About to use soap client 140438892380368 for method loginRequest
2011-07-28 16:58:24.060 ERROR [CP WSGIServer Thread-3] [gwsoap:611] [userID:test] [eventID:] [objectID:] [] Could not redirect user! Error: <urlopen error [Errno 1] _ssl.c:482: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol>
2011-07-28 16:58:24.061 WARNING [CP WSGIServer Thread-3] [gwuser:510] [userID:test] [eventID:] [objectID:] [configureUser] Failed to login to user! Can not complete this users configurations without logging in.

And this is what the POA log says:

16:58:23 944 Http: Error(892b) request from 192.168.2.4 user agent[Python-urllib/2.6] session(SOAP)
16:58:28 944 Http: Error(892b) request from 192.168.2.4 user agent[Python-urllib/2.6] session(SOAP)
16:58:33 944 Http: Error(892b) request from 192.168.2.4 user agent[Python-urllib/2.6] session(SOAP)

Both POA:s are internal and runs on the same server (diffrent IP:s) Telnet to POAs from Mobility server on SOAP ports are ok.
My trusted App key is generated without an IP address filled in.
Primary PO works fine

/ Gunnar