Hi,

I found exception error in engine.log. It happened every time I restart the engine. Looks like I have the error since day 1 I setup DS. Do I need to worry about this? I just updated to v1.2 this afternoon but I found these error in April, 2011 (when I set it up)

Engine Log:
2011-08-31 16:39:26.274 INFO [MainThread] [engine:331] [userID:] [eventID:] [objectID:] [] Connected to database...
2011-08-31 16:39:26.316 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.source.soap
2011-08-31 16:39:26.324 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.deli
2011-08-31 16:39:26.336 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.fold
2011-08-31 16:39:26.346 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.xslt
2011-08-31 16:39:26.352 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.targ
2011-08-31 16:39:26.359 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.enab
2011-08-31 16:39:26.361 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.cach
2011-08-31 16:39:26.364 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.targ
2011-08-31 16:39:26.368 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.inje
2011-08-31 16:39:26.371 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.obje
2011-08-31 16:39:26.372 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.pass
2011-08-31 16:39:26.377 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.filter.logg
2011-08-31 16:39:26.383 INFO [MainThread] [engine:526] [userID:] [eventID:] [objectID:] [] Loaded plugin: engine.sink.soapbr
2011-08-31 16:39:26.438 INFO [MainThread] [engine:334] [userID:] [eventID:] [objectID:] [] Loaded 13 plugins from 4 connecto
2011-08-31 16:39:26.439 INFO [MainThread] [engine:1065] [userID:] [eventID:] [objectID:] [] Creating diagnostic log for targ
2011-08-31 16:39:26.448 INFO [MainThread] [engine:538] [userID:] [eventID:] [objectID:] [] Found pipeline: pipeline1
2011-08-31 16:39:26.718 INFO [MainThread] [engine:552] [userID:] [eventID:] [objectID:] [] Found connector: default.pipeline
2011-08-31 16:39:26.797 INFO [MainThread] [engine:552] [userID:] [eventID:] [objectID:] [] Found connector: default.pipeline
2011-08-31 16:39:26.797 INFO [MainThread] [engine:556] [userID:] [eventID:] [objectID:] [] Loading policies for default.pipeline1.groupwise...
2011-08-31 16:39:29.094 INFO [MainThread] [engine:556] [userID:] [eventID:] [objectID:] [] Loading policies for default.pipeline1.mobility...
2011-08-31 16:39:30.684 ERROR [MainThread] [util:248] [userID:] [eventID:] [objectID:] [] EXCEPTION: ********************
2011-08-31 16:39:30.684 ERROR [MainThread] [util:251] [userID:] [eventID:] [objectID:] [] EXCEPTION: Traceback (most recent call last):
2011-08-31 16:39:30.684 ERROR [MainThread] [util:251] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "./engine/filter/targetFromAI/filter.py", line 41, in init
2011-08-31 16:39:30.684 ERROR [MainThread] [util:251] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "syncengine/lib/syncengine/xslt/__init__.py", line 17, in loadStylesheetWithExtensions
2011-08-31 16:39:30.684 ERROR [MainThread] [util:251] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "xslt.pxi", line etree.XSLT.__init__ (src/lxml/lxml.etree.c:107747)
2011-08-31 16:39:30.684 ERROR [MainThread] [util:251] [userID:] [eventID:] [objectID:] [] EXCEPTION: XSLTParseError: xsltParseStylesheetTop: unknown choose element

Thanks,
Aldous