Results 1 to 7 of 7

Thread: ZCM 11 Boot image instructions

Threaded View

  1. #1
    Join Date
    Apr 2009

    ZCM 11 Boot image instructions

    I thought I should share some information on how I made my bootable ZCM 11 USB memory stick that automaticly starts and restores an offline image.

    As I didnt find any complete easy way of doing this it took me three days of trail and error to get what wanted.

    I have tried this on 4-16gb and it has so far worked everytime.

    This is what I did:

    1. Format USB memory stick as fat32

    2. Run unetbootin-win-549.exe

    3. Point out bootcd.iso (found in zenworks driver updates) and execute

    4. make a img folder on usb stick

    5. add "install=hd:/dev/sdb1 root=/dev/sdb1" to every command line that
    starting with "append " in syslinux.cfg

    efault menu.c32
    prompt 0
    menu title UNetbootin
    timeout 3

    label unetbootindefault
    menu label Default
    kernel /ubnkern
    append initrd=/ubninit ramdisk_size=67584 splash=silent mode=2 CDBOOT=YES showopts vga=0x0314 install=hd:/dev/sdb1 root=/dev/sdb1
    label ubnentry0
    menu label linux
    kernel /boot/i386/loader/linux
    append initrd=/boot/i386/loader/initrd ramdisk_size=67584 splash=silent mode=2 CDBOOT=YES showopts vga=0x0314 install=hd:/dev/sdb1 root=/dev/sdb1

    6. add three lines in the bottom section of the settings.txt file.

    mkdir mnt/usb
    dev/sdb1 mnt/usb

    7. Make a win7.s script file and here you should enter the name of the image that you copied to the img folder

    img -restore -local mnt/usb/img/win7x86.zmg

    Side note : Only use Notepad++ and when saving save in unix format

    Problems that I encountered:

    When using the "img -restore -local mnt/usb/img/win7x86.zmg" in the settings.txt instead of pointing out a script file the imageing process looped and restored the same image file over and over again in all eternity. Dont know why

    Adding script files to addfiles on memory stick dont work, this seems to be a know error that could be fixed if you know Linux, I dont so i put the image script directly in the fat32 part of the memory instead.

    I hoped I have helped someone out there to save some time.
    Last edited by bnrn; 08-Sep-2011 at 11:31 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts