Hello, I'm going to upgrade my BM3.7 server on NW6sp5 to 3.8 on NW65sp2. I have several C-S VPN users running the bm37vpn4 client. Do I need to upgrade the clients before the server upgrade, or is the server also backward compatible with the 3.7 client? Thanks much.